Jump to content

Recommended Posts

I just tried to place my first order with the web shop and failed.  It feels stupid, like there's something I've missed - and I shop online a lot, but the method they're using for credit card info wasn't working for me at all.  It was there on the page but when I tried to click on "credit card number" no field opened up.  It appears to be a mechanism called "Square" - do I have to register for that?

I've emailed Rob but it's Saturday.  Anybody know?  Thanks.

@MED-EL Moderator

Share this post


Link to post
Share on other sites

@Mary Featherston

Hmmm.....I placed an order through the Med-El online shop once and I believe my credit card went through or was there a paypal option?  I can’t remember.

I don’t use that shop much since my insurance covers things I need and you can’t go through insurance via the online shop.

Share this post


Link to post
Share on other sites

@Mary Beth yeah, it was weird.  I may try again later, maybe the page just didn't load completely.  I wasn't going to bother with the insurance for the this - I just want replacement tethers.  Insurance covers my mic covers, but they'll never pay for them due to my deductible.  I don't have a lot of medical expenses, so I never do meet the deductible (other than last year, with both CI surgeries).  So I was just going to order them myself.  I can use my HSA.

Share this post


Link to post
Share on other sites

@Mary Featherston

If you want replacement tethers for Rondo 2 that are already attached to the hair clip or shirt clip, you may want to wait and contact your CSR.  The last time I looked the web shop only shipped the tethers separately and people here have commented on how difficult it is to attach the replacement tethers without breaking them.  Just something to consider.

Share this post


Link to post
Share on other sites

@Mary Beth I've emailed Rob, my CSR, already.  We'll see what he says. 

Share this post


Link to post
Share on other sites
On 8/3/2019 at 5:24 PM, Mary Featherston said:

I just tried to place my first order with the web shop and failed.  It feels stupid, like there's something I've missed - and I shop online a lot, but the method they're using for credit card info wasn't working for me at all.  It was there on the page but when I tried to click on "credit card number" no field opened up.  It appears to be a mechanism called "Square" - do I have to register for that?

I've emailed Rob but it's Saturday.  Anybody know?  Thanks.

@MED-EL Moderator

Hi @Mary Featherston, Sorry to read that you have had problems with this. Unfortunately i cannot access the Webshop from here in Austria so I can't check this for you, but the customer service team in the US will be able to help if you are still having problems. Their details are: Tel.: 888-633-3524E-Mail: customerservice.us@medel.com . Kind regards, Mary  

Share this post


Link to post
Share on other sites

Hey @Mary Featherston

I encountered the same problem problem with the webshop. It kept freezing after I entered my credit card details. I order online from various US supplies and have never had a problem. I suggested to US Med-El that they have a PayPal option. In the end I had to call in my order. 

I'm curious as to what your CSR says. 

Share this post


Link to post
Share on other sites
11 hours ago, MED-EL Moderator said:

Hi @Mary Featherston, Sorry to read that you have had problems with this. Unfortunately i cannot access the Webshop from here in Austria so I can't check this for you, but the customer service team in the US will be able to help if you are still having problems. Their details are: Tel.: 888-633-3524E-Mail: customerservice.us@medel.com . Kind regards, Mary  

Thanks, Mary!  I emailed Rob and sent him a screen shot, so he's going to forward it to someone who can help.

@Jewel your problem sounds different, I can't even get to the fields to enter my credit card number.

Share this post


Link to post
Share on other sites

Try to use different browser sometimes because of web browser you will got this issues @Mary Featherston

Share this post


Link to post
Share on other sites
16 hours ago, iHM24 said:

Try to use different browser sometimes because of web browser you will got this issues @Mary Featherston

Oh, you know, I should have thought of that, thanks, Hameed.

Share this post


Link to post
Share on other sites
8 hours ago, Mary Featherston said:

Oh, you know, I should have thought of that, thanks, Hameed.

 

You’re welcome dear @Mary Featherston

Share this post


Link to post
Share on other sites
13 hours ago, iHM24 said:

 

You’re welcome dear @Mary Featherston

And it worked!  Thanks again Hameed @iHM24.

And for everyone:  apparently Firefox isn't popular among the Med-El web developers.

Share this post


Link to post
Share on other sites
7 hours ago, Mary Featherston said:

And it worked!  Thanks again Hameed @iHM24.

And for everyone:  apparently Firefox isn't popular among the Med-El web developers.

I’m happy to hear that dear @Mary Featherston . Enjoy your shopping 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...