Jump to content
Mary Beth

Experience upgrading from Rondo to Rondo 2

Recommended Posts

@Jdashiell

Are you finding yourself using your Sonnets as your primary processors now?

Share this post


Link to post
Share on other sites

@Jdashiell Clever of you to discover the clicking problem with your Sonnet. Nice going! As you know, the Rondo2 doesn’t have a removable battery (by the user, at least), so there’s no option to change to disposable batteries. However, I just heard back from my audiologist that she thinks the cause of the ticking in my Rondo2 t-coil has been resolved and she will install a fix for me later this week. I hope she’s right! 

Share this post


Link to post
Share on other sites

@Mary Beth

@Valentin

i haven’t forgotten the test I’m going to do with the portable charger...it will just have wait a week or so. I sent my processors to my audiologist for a fix to the ticking issue but she’s away from her office til Friday. I’ll test it as soon as I get them back and let you know the results.

Share this post


Link to post
Share on other sites
15 minutes ago, Mary Beth said:

@Jdashiell

Are you finding yourself using your Sonnets as your primary processors now?

Yes I am

Share this post


Link to post
Share on other sites

@Mary Beth don't worry, take your time. Try it with some charges with same powerbank charge to know what could be the performance. Take note about mAh of your powerbank for better accuracy. It's not the same a 2000 mAH that 4000 mAh powerbank.

 

 

 

Share this post


Link to post
Share on other sites

@Valentin

You understand this stuff way better than me.  Here is a link to the power pack that @Joan will be using to see how many times she can charge up her Rondo 2 processors from one full power pack charge.  She will be charging up two Rondo 2 processors each night since she is bilateral.

 

https://www.amazon.com/gp/aw/d/B01ISO92V2?psc=1&ref=ppx_pop_mob_b_asin_title

Share this post


Link to post
Share on other sites

10400 mAh, good choice... 

Share this post


Link to post
Share on other sites

@Mary Beth

@MED-EL Moderator
 

Regarding the “ticking” issue in the t-coil which I experienced during the recent activation of my Rondo2s (see my earlier posting in this topic), I’m very pleased that the issue was addressed and successfully resolved very promptly by Med-El and my audiologist. Although I do not know the technical aspects of either the problem or the “fix”, my audiologist has applied the fix to my processors and the ticking is now gone.

To any other Rondo2 user who may be experiencing a similar issue with the t-coil, I suggest you contact your audiologist to have the fix applied to your processor(s).

Share this post


Link to post
Share on other sites

That was a quick fix!  I am happy the ticking sound on your Rondo 2 processors when on MT/T is gone @Joan!

Share this post


Link to post
Share on other sites

@Mary Beth

It certainly was a quick fix! I’m a happy camper!😊

Share this post


Link to post
Share on other sites

@Joan: Hi Joan, that's great news! Wonderful to hear that your issue was solved :) Best regards, Verena 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...