Jump to content

norman johnson


robert21
 Share

Recommended Posts

Can anyone advise me please, I had my implant in February, it is the one with a internal mike and a external  mike so I can choose which to use. The problem I am having is that the external mike gives me a constant sound like a un tuned radio all the time, even when switched off. UCH hospital l tells me they can’t do anything about it. Is this normal, in a quiet environment the sound is louder than the person I am talking to.

Link to comment
Share on other sites

  • HearPeers Heroes

@robert21

That sounds frustrating.  What is the name of the processor you are using.

Link to comment
Share on other sites

it is a "MET-7000" i don't know if anyone else has the same problem

Link to comment
Share on other sites

  • HearPeers Heroes

@robert21

I see.  That is a middle ear implant I believe.  It is not a Med-El brand middle ear implant.  This forum is hosted by Med-El so almost all members here have Med-El brand implants.  Some people with other brand implants are here to share our common experiences.  I have not read a post here by anyone who has your brand of middle ear implant.  I’m sorry I don’t have any info that may help you.  I hope this gets sorted out soon for you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...