Jump to content

Constant failed battery beeps


Darren
 Share

Recommended Posts

Heading to work today my Sonnet started the constant failed battery beeping, then shuts down. Brand new batteries that i purchase from medel here in canada.  I had this issue twice before, happens with both rechargeable batteries and disposable.  I see in the forum this seems to be a consistent issue. I sent off an email to Union hearing aid, hopefully will hear back to exchange my two battery covers Monday. But does anyone know if medel is going to bring out an improved version or upgrade?  I require my implant to be safe at work, so its a huge problem when they don’t work. 

Link to comment
Share on other sites

  • HearPeers Heroes

@Darren

I have experienced that with my Sonnet when using ZeniPower batteries from Med-El US.  When I asked to be switched back to PowerOne Implant batteries from Med-El US, that problem disappeared.  I’ve been using PowerOne Implant batteries everyday with my Sonnets with no false dead battery beeps.

Suggestions:

1) If not already using PowerOne implant batteries, try them.  If using them already, try a different box.

2) Clean the battery contacts.  Med-El has a YouTube video showing how.

3) check the Sonnet form ring to be sure it is not stretched or torn.  

4) Try a different battery cover

Link to comment
Share on other sites

I am using PowerOne batteries exclusively  I purchase them in bulk from Union Hearing in Toronto.  I have cleaned the contacts on both of the battery frames I have with no improvement.  I've tried 2 different body covers.  The O ring looks fine, all I could do there would be to remove it and try that.  

So to recap, I have 2 battery covers, and two battery frames ( I LIKE having spare parts, I'm a millwright by trade) and have tried them in all combinations.  In every case I get battery chirp within 3-4 minutes of switching on.  New batteries make no difference.  All I can extrapolate from this is that either the controller is bad (it's already been replaced under warranty once) or the frames and/or covers are bad.  either way i'm stuck till I hear back (I hope) on monday morning.  It's just I work a weekend shift.  I am lucky in that I was able to purchase a Rondo 2 when I recieved my first Sonnet and am currently wearing that, but I HATE using it at work as I am constantly worried about loosing it.  I have to wear a hard hat and the head band scrapes it off constantly.  I purchased a medel headband for use when playing sports and that is working well (first time using it due to covid) but I prefer the security and better sound quality of the sonnet when at work.

Link to comment
Share on other sites

  • HearPeers Heroes

Definitely sounds like a problem with the control unit since you have swapped out most everything else.  Have you detached the cable and checked it?

Link to comment
Share on other sites

  • HearPeers Heroes

@Darren

This ended up being my problem with battery and Sonnet recently.  It must’ve been stretched and not closing correctly because after it tore and was replaced the problem disappeared.

 

Link to comment
Share on other sites

mine is in good shape, but it is original.  My work exposes it to lots of dirt, dust and some oil, perhaps it is swollen or gone hard.  I will order a couple of new ones monday and see how it goes

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...