Jump to content

Fine Tuner echo - help!


SarahH
 Share

Recommended Posts

Hello- I have a Rondo 3 and the fine tuner echo screen is frozen on this (see pic) . I have tried opening and closing battery with no luck. The only button that works is the un/lock then screen returns to this and I’m unable to use any other functions- any help would be greatly appreciated. 

D61EFD8D-9227-42A8-A1F1-5AFDF3A33EFF.jpeg

Link to comment
Share on other sites

  • HearPeers Heroes

Have you tried pairing your Rondo 3 to the FineTuner Echo again?

Link to comment
Share on other sites

10 minutes ago, Mary Beth said:

Have you tried pairing your Rondo 3 to the FineTuner Echo again?

Hi Mary Beth, thanks for your suggestion. I have tried to re-pair it , with no luck 🥺

Link to comment
Share on other sites

  • HearPeers Heroes

According to the user manual this symbol represents a pairing issue.  If you are in the US, you can contact in house audiology for help.

 

8583C41B-B994-449D-B939-1BFBE32E5628.jpeg

Link to comment
Share on other sites

1 minute ago, Mary Beth said:

According to the user manual this symbol represents a pairing issue.

Actually @Mary BethIf there is as pairing issue we would see the "X" in the display. It looks like to me from the above picture that it's just waiting to be paired for the first time.

Link to comment
Share on other sites

Thanks guys! I’m in Australia- I have a mapping appointment on Friday, I’ll ask the team then. Thank you 😊 

Link to comment
Share on other sites

@SarahH did you try to reset option from the manual stated above?

Remove the battery, press the 3 buttons until the light comes on and then off, then reinsert the battery.

Link to comment
Share on other sites

Thanks Dennisjbr! That did the trick !!!

  • Like 2
Link to comment
Share on other sites

Yeah!!!!  Good to know and good for me to know when i need that with the FineTuner Echo!  

 

Link to comment
Share on other sites

  • 7 months later...
On 8/3/2021 at 9:06 PM, Dennisjbr said:

I wanted to try my replacement sonnet 2 EAS device to see how it works. It works, but its fine tuner echo is unresponsive.  I tried the workaround listed above and fine tuner is still unresponsive.  I attached a pic of how the screen looks now.     Any  suggestions will be greatly appreciated.

finetunerecho.jpg

Link to comment
Share on other sites

  • HearPeers Heroes

@Juan P

Did you pair your Sonnet EAS to the fine tuner echo first?

 

 

Link to comment
Share on other sites

Thanks again, Mary Beth!

Yes, it was done by the radiologist in my last programming. The fine tuner echo is just for the replacement device to use  just in case.   I used it shortly after the programming to check it and it worked.  I then used my main device ( used audiokey 2 to control the main device) and forgot about the replacement. When I tried to use it again this week,  I noticed that the fine tuner echo is no longer responsive.  The device works though. I attached a pic of how the tuner screen looks like in my original post.

J

P.S.  My audiostream is still not working ( I am supposed to receive a new audio stream cover and then someone from Audiology is going to help me).

Link to comment
Share on other sites

  • HearPeers Heroes

@Juan P

If it was me, I would make sure I had new batteries in the Sonnet and go through the steps to sync it with the Fine Tuner Echo again.

new batteries and resyncing would be my first steps

Link to comment
Share on other sites

12 minutes ago, Mary Beth said:

@Juan P

If it was me, I would make sure I had new batteries in the Sonnet and go through the steps to sync it with the Fine Tuner Echo again.

new batteries and resyncing would be my first steps

Thanks again, Mary Beth!

Yes, it was done by the radiologist in my last programming. The fine tuner echo is just for the replacement device to use  just in case.   I used it shortly after the programming to check it and it worked.  I then used my main device ( used audiokey 2 to control the main device) and forgot about the replacement. When I tried to use it again this week,  I noticed that the fine tuner echo is no longer responsive.  The device works though. I attached a pic of how the tuner screen looks like in my original post.

J

P.S.  My audiostream is still not working ( I am supposed to receive a new audio stream cover and then someone from Audiology is going to help me).

I just tried again with the most recent recharged battery and followed the steps in the med-El video to sync and no luck.  It is still unresponsive. The screen remains  frozen, as shown in the pic.

Thanks for your suggestions

Link to comment
Share on other sites

  • HearPeers Heroes

@Juan P

Maybe Med-El in house audiology can assist you.

Sorry it is not responding.

Link to comment
Share on other sites

Many thanks for all of your efforts,! I am just not lucky. I will contact them.  J

Link to comment
Share on other sites

  • HearPeers Heroes

@Juan P

let us know how things go

Link to comment
Share on other sites

  • 2 weeks later...

Hi! My  sonnet2 for some reason did not seat well with the rechargable tray. I received a replacement in a few days works great!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...