Jump to content

Rondo 3 telecoil adapter


John Crozier
 Share

Recommended Posts

Hi, John has been using the Rondo 3 since August 22 and it has beeen an improvement over the Sonnet.  He is experiencing a constant ticking sound when using telecoil.  Is anyone else having a similar experience?  He likes the Artone 3 max but can’t use it because of the ticking.  Any advice would be appreciated.   

 

 

 

 

Link to comment
Share on other sites

  • HearPeers Heroes

@John Crozier

The constant ticking sound when using telecoil was a problem with Rondo 2 processors.  @Joan reported it to her audiologist and then Med-El US in house audiology looked into it.  I believe the way to stop the ticking sound when using telecoil with Rondo 2 is to have the auto off features/link monitoring features disabled.  Joan will know more.  This is the first I am reading about the ticking telecoil issue with Rondo 3.  That’s unfortunate.

Link to comment
Share on other sites

@John Crozier , @Mary Beth is correct. I did have that same issue, ticking when using the telecoil, with my Rondo2s and my audiologist eventually found a fix. It did involve disabling a feature which, I believe, is as Mary Beth described. I will try to get confirmation of that from my audiologist.

Link to comment
Share on other sites

Thank you Joan and Mary Beth.  I would really appreciate getting this information to stop the ticking.  I am looking forward to your response

Link to comment
Share on other sites

@John Crozier This is the response I just received from my audiologist:

        “It is the "Link Check of the D-coil technology."   The Audiologist should     deactivate the Link Check and see if that solves the problem.”

I hope you can see your audiologist soon and I hope this solves your problem. Good luck!

 

Fyi, @Mary Beth.

Link to comment
Share on other sites

@Joan Thanks for getting in touch with your audiologist for us.  I was unaware this ticking was a known problem with the Rondo 2 as well.  I will send this to our Audi and see if this is the answer we are looking for.   Thanks again we’d be so happy to have it resolved.  I will let you know how it goes.  Thanks @Mary Beth too.

  • Like 2
Link to comment
Share on other sites

@Joan, @Mary Beth, regarding the ticking on the telecoil for Rondo 3……. I contacted our audiologist and gave them the information about Link Check of the D coil technology but she says we already tried this at our last appointment.  I was really hoping for a fix but we are not there yet.  I hope someone posts if they find an answer.  Thanks for the help.  We appreciate it.

Link to comment
Share on other sites

  • HearPeers Heroes

@MED-EL Moderator

Do you have guidance on what settings need to be changed in Rondo 3 to avoid hearing a ticking sound while the telecoil adapter is in use?

Link to comment
Share on other sites

I admit this piqued my curiosity. For the sole sake of testing a listening scenario out, I grabbed my adapter and plugged it in. Immediately got clicking/buzzing as well, streaming did not get rid of it.

Just adding this as we have the same processor. 

Link to comment
Share on other sites

@Lauren I’m sorry you are experiencing the same clicking. Unfortunately, the fix that worked for my Rondo2s does not appear to work for the Rondo3, as mentioned by @John Crozier.

I certainly hope @MED-EL Moderator will be able to provide some insight into fixing the issue you Rondo3 users are experiencing. Thank you @Mary Beth for posing the question to Med-El.

Link to comment
Share on other sites

Thanks @Lauren for posting this.  It’s a very annoying constant sound so John is not using the Artone 3 max any more which he prefers for phone and tv.  I hope with more people chiming in on this maybe it will get resolved faster. At least we now know we are not the only one with the issue.  Our Audi changed processor, telecoil, turned off the lights etc and nothing helped.  Looking forward to a quick resolution.  

Link to comment
Share on other sites

My first guess is it’s something wrong with the adapters we both have, as I use telecoil with my Sonnet 2 with no issues. The adapter is the only thing different for me in regards to my use of telecoil with Sonnet 2/Rondo 3. 

Link to comment
Share on other sites

  • HearPeers Heroes

@John Crozier and @Lauren and @Joan

 

I reached out to in house audiology at Med-El US and they responded.  I asked if I could share this on the HP forum and they said yes as it is the information they would give any user who contacted them about it.

Yes, we have also heard these reports and we are looking into why this is happening.  In the interim, please see two suggestions below which will help eliminate the noise.  These are not ideal, but are effective.

 

  1. Remove the telecoil adapter when not actively using it.
  2. Put the RONDO 3 in FLIGHT mode.  Unfortunately, this will also not allow you to use accessories such as the ECHO remote or the AudioKey2 app.
  3. If you happen to have a SONNET or SONNET 2, using it would be another solution as the Telecoil is integrated and we have not had any reports of the clicking with its use.”

 

 

Link to comment
Share on other sites

Thanks @ Mary Beth.  I will try this today.  

@Joanwe had a lengthy troubleshoot at our last audi appointment a few weeks ago for this issue.  We changed the telecoil adapter, processor and turned off the start up lights.  None of these changes had any affect.  If this works, it will help in the short term but wouldnt want to have to do this each time we use telecoil.  I wonder if pressing that on and off so much would it wear the button or present other problems?  Grateful for this info today.   Have a good day everyone

  • Like 3
Link to comment
Share on other sites

  • HearPeers Heroes

Keep us posted @John Crozier.  Fingers crossed that this work around suffices until a more permanent fix is offered.

  • Like 2
Link to comment
Share on other sites

HI,  I tried putting the Rondo 3 in flight mode five times and somehow I am not getting it.  It sounds so simple but I either wait too long between or press too long and it doesnt work.  After 5 times I stopped trying because I am afraid to break anything and then John will be lost with no hearing until a repair is done.  I dont know if anyone else will try this but I am also wondering @Mary Bethif this flight mode could be put in one of our programs so we dont have to go through this.  I am also wondering if @Joanyou have tried the flight mode.  I will have to get it right because if we want to travel anytime we have to use flight mode.  I will give it a try again and if I get it I will let you know.  Its embarassing not being able to do what seems so simple.  LOL. Have a great day.

Link to comment
Share on other sites

@John Crozier I have Rondo 2s which don't have a flight mode so, unfortunately, I'm not able to help you with this issue. I hope someone with a Rondo 3 will be able to try it for you. Good luck!

Link to comment
Share on other sites

https://www.medel.com/en-us/support/product-support/audio-processors/rondo3/handling-and-basics/rondo3_handling_flightmode
 

These steps worked for me. Tried it twice to be sure.

The processor light will turn on then go solid white and fade out like normal. After the white fades out, blue comes on and that is when you turn it off. The last time, it’ll at first seem like the first 3 times but will do 2-3 rapid red blinks after you see the blue light. Just need to turn it off/on 3 times, and turn it on for a 4th time.

I put the adapter in to test and there was no constant clicking. At first there was 2-3 crackling sounds but it did not last long, less than 10 seconds if I was guessing. Didn’t try streaming anything tho. 

Link to comment
Share on other sites

@Mary Beth thanks for tagging us! 

 

 @John Crozier Unfortunately there is no video available for this, but you can find the instructions on how to activate the flight mode for RONDO 3 on our website: https://www.medel.com/support/product-support/audio-processors/rondo3/handling-and-basics/rondo3_handling_flightmode 

Hope that helps! 
Best wishes, Verena 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...